Users experiencing 504 errors and page load delays

Incident Report for CodeHS

Resolved

This incident has been resolved and site performance has been stabilized.
Posted Aug 26, 2025 - 08:12 PDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Aug 25, 2025 - 09:38 PDT

Investigating

We are currently investigating.
Posted Aug 25, 2025 - 07:41 PDT
This incident affected: Main Website.